Back to overview
Degraded

Site is slow.

Dec 23 at 04:41pm GMT

Resolved
Dec 23 at 04:41pm GMT

The slow site is sorted.

Created
Dec 23 at 04:41pm GMT

The main JCore site is slightly slow. We ar working on this.